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Troubleshooting Microsoft 365 Integration & Notification Issues

This troubleshooting guide helps you identify and resolve common Microsoft 365 email integration errors to ensure your notification workflow remains uninterrupted.


Mail Send Permission Removed

Symptoms:

  • The User (Administrator/ Member) will receive an error notification when the Microsoft 365 mail sending permission is revoked on their account by IT.
  • Guests will stop receiving any booking-related email notifications including confirmations, reschedules, or cancellations.

Cause:  

The Mail.Send permission for the OnceHub application has been revoked in Azure AD. Once revoked, OnceHub cannot send emails on behalf of the user.

Resolution:

The easiest way to restore the permission is to re-establish the connection.

  1. Click on your profile picture in the top right-hand corner.
  2. Select User Integrations.
  3. Reconnect your Microsoft 365 account.

NOTE: During the re-connection process, ensure that full email permissions are granted either by the User or on behalf of the organization.


Mailbox Quota Exceeded

Symptoms:

  • The User (Administrator/Member) will receive an error notification when their mailbox storage quota is full.
  • Guests will not receive any booking-related email notifications until storage space is freed.

Cause:  

The User’s Microsoft 365 mailbox has reached its storage limit or exceeded its sending quota, preventing OnceHub from sending notifications.

Resolution:

To fix this issue, the User/ Administrator responsible for managing mailbox settings should follow these steps:

  1. Go to the Microsoft 365 Admin Center.
  2. Navigate to Users → Active Users → [Select the User] → Mail tab.
  3. Review the current storage and quotas. For detailed Microsoft guidance on managing storage, see Mailbox Storage Quotas.
  4. Retry sending notifications from OnceHub.
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